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Getting Started 
 
STARTING CONTRIBUTE WITH A KEY 
In order to connect to your departmental Web space, use the Contribute Key that has been 
designed by the Web Master for your department. These keys can be found at the 
following location: 
 
Windows Users: 
\\www.ed.uiuc.edu\edwebs\keys 
 
Mac Users: 
smb://www.ed.uiuc.edu/edwebs/keys 
 
To Start Contribute with a Key 

1. Locate your Contribute Key and double-click on it 
2. When prompted for a password, enter your password and click on OK. If you 

have forgotten your password, contact the TLC at 244-6053. 
 
CREATING A NEW FILE 

1. Click on the New Page tool in the toolbar at the top of the screen  
2. Click on the Refresh Templates button at the bottom of the dialog box 
3. Under Templates, choose either the Standard or Standardsidebar template 

Note: If a Debugger window appears, click on NO. To turn off the debugging, do 
the following: 

a. Start Internet Explorer 
b. From the Tools menu, choose Internet Options 
c. Click on the Advanced tab 
d. The fourth item under Browsing should be Disable Script Debugging. 

Click on it’s checkbox to check it and click on OK. 
4. Enter a title for the Page in the Page Title area, making sure to remove the < > 

that are around Enter Title, and click on OK. 
5. Triple-click on the words Standard Template and type the heading for the page. 

 
SAVING A FILE FOR LATER USE 
To save a file, but not publish it to your Web site, yet: 

1. Click on the Save For Later tool at the top of the screen  
2. The file will now show in the pane in the upper left-hand corner of the screen 

 
SEND FOR REVIEW 
Before you publish a page, you can send it for review. 

1. Click on the Send for Review button in the top toolbar  
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2. Click on the first option button (Send e-mail with a link to a preview of the 
draft) and click on Send 

3. A new email message should display that contains a link to the draft page. 
4. Address the email to the reviewer and send the email. 
5. The date and time you sent the review will be shown in the yellow bar at the top 

of your screen. To view the version of the page you sent for review, click on the 
Click Here link. 

 
PUBLISHING A FILE 
Once a file is ready to go live on your Web site, it needs to be published. 

1. Click on the Publish tool at the top of the screen  
2. If the following screen is displayed, click on Yes 

 

 
 

3. Enter a Filename.  Refer to the section on FileName Conventions listed below 
this section when deciding on filenames. 

4. Click on the Choose Folder button 
5. Double-click on the folder to be saved to and click on the Select button at the 

bottom of the dialog box. 
6. Click on the Publish button.  When the Congratulations screen displays, click on 

OK. 
 
Filename Conventions 

• Lowercase Letters 
• No Underscores 
• No Spaces 
• Limit to 20 characters 
• File Extension should be .html 

 
OPENING A FILE FOR EDITING 
Open a File that was Saved for Later Use 

1. Look for the page to be edited in the Pages area on the Sidebar at the left-hand 
side of the screen. (If the sidebar is not displayed, from the View menu, choose 
Sidebar) 

2. Click on the file and it will automatically open in the edit mode 
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Browse to Web Address 
1. In the Address bar at the top of the screen, type the Web address of the page to be 

edited. 

2. Click on the Edit Page tool on the toolbar at the top of the screen  
 
Choose File from a Server Location 

1. From the View menu, choose Choose File on Web Site 
2. Navigate to the desired file and double-click on it. 

3. Click on the Edit Page tool on the toolbar at the top of the screen  
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Entering Text and Formatting 
PAGE PROPERTIES 
When a new page is created from a template, a Page Properties section will appear at the 
bottom of the page. This section does not show on your page in a Web browser. It is used 
to set specific properties of the page such as keywords and path bar name. 
 
Page Properties Items 
Item Description 
Description This description shows when a user finds the Web page in 

search 
Keywords These words are used by search engines to find the page. 

Separate the words with spaces. 
Path Bar Name Text entered here displays in the path bar at the top of the 

page. 
Update Reminder Date If a page is visited after this date, the author will receive a 

reminder email to update it. 
Author Information Enter the page author’s information. If you would like a link to 

the author’s email address to be displayed on the page, type 
Yes in the usefeedbackform box. 

Level 1 Menu Item 
Name and Level 2 
Menu Item Name 

These two fields determine which menu item is highlighted in 
the left side menu. If the page you are working in is in the 
menu under the major heading “About the College” and the 
minor heading “Welcome”, you would put “About the 
College” in the Level 1 Menu Item Name box and “Welcome” 
in the Level 2 Menu Item Name box (do not include the 
quotes). These fields may be left blank. 

Feedback Form To include a feedback link on this page, enter Yes in this field 
Hide Email If set to Yes, will not display the email address from the 

Author Information or default contact information 
Page Notes Enter documentation about the page in this area. 
 
 
FORMATTING TOOLBAR 

 
 
 
 
 
 
 

Bold Italics Alignment 
Tools 

Styles 

Numbered 
List

Bulleted 
List

Outdent 

Indent 
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STYLES 
Styles are pre-defined formatting used for titles and paragraph headings. When you 
create a new page using the standard or standardsidebar template, the first line of the page 
is in the Heading 1 style.  To type a new title there, triple-click on the title and type the 
desired text. After typing the title, press Enter and the style will change to Normal. 
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Tables 
 
INSERTING A TABLE 

1. Click on the Table tool in the toolbar at the top of the screen  
2. In the Insert Table dialog box, choose the number of rows and columns.  
3. The following Options can also be set: 

 
Option Description 
Border thickness This is the thickness of the lines around the cells of the 

table. Increase the number to make a thicker border. Tip: 
for no border, enter 0 

Cell padding This is the space inside a cell between the border and the 
text. (Inside margin of the cell.) 

Cell spacing This is the space between cells. 
Headers Shades cells according to the header chosen. Screen 

readers will read text from the cells formatted in these 
heading types. 

 
4. Click on OK. 

 
ENTERING DATA IN A TABLE 
Cursor Movement Key(s) to Press 
Move to the next cell Tab 
Move to the previous cell Shift-Tab 
Enter a New Line at the end of the table Press the Tab key while in the last cell of the 

table. 
 
 
CHANGING COLUMN WIDTH 

1. Point to the right border of the column to be sized. 
2. When the mouse pointer changes to a double-black arrow, click and drag. 

 
Tip:  To set the specific width of a column or several columns at once, select the 
columns, right-click in the selected columns, and choose Table Cell Properties 
 
CHANGING ROW HEIGHT 

1. Point to the bottom border of the row to be sized. 
2. When the mouse pointer changes to a double-black arrow, click and drag. 

 
Tip:  To set the specific height of a row or several rows at once, select the rows, right-
click in the selected rows, and choose Table Cell Properties 
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CHANGING TABLE PROPERTIES 
To change properties of a table, such as cell border, cell padding, cell alignment, etc.: 

1. Right-click in the Table 
2. Choose Table Properties 

 
CHANGING CELL PROPERTIES 
To change cell properties, such as alignments and background color: 

1. Right-click in the selected cells 
2. Choose Table Cell Properties 
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Hyperlinks 
HYPERLINK TO WEB ADDRESS 

1. Select the text or graphic to link 

2. Click on the Link tool in the toolbar at the top of the screen  
3. Choose Browse to Web Page 
4. Type the Web address or click on the Browse button and enter a Web address in 

the Address bar and click on OK. 
5. Click on OK 

 
HYPERLINK TO E-MAIL ADDRESS 

1. Select the text or graphic to link 

2. Click on the Link tool in the toolbar at the top of the screen  
3. Choose E-mail Address 
4. Type the email address and click on OK 

 
 
HYPERLINK TO A FILE ON THE WEB SERVER 
In Contribute 3 you can now easily link to a file on your Web server. 

1. Select the text or graphic to link 

2. Click on the Link tool in the toolbar at the top of the screen  
3. Choose Browse to Web Page 
4. Click on the Choose button (Search your web server for the file you want to link 

to) 
5. Navigate to the file and click on OK 
6. Click on OK 

 
HYPERLINK TO A SPECIFIC SPOT ON A PAGE (ANCHORS) 
Anchors 
In order to hyperlink to a specific spot on a page, an anchor needs to be inserted at the 
spot. To create the anchor: 

1. Select the text to anchor 
2. From the Insert menu, choose Section Anchor 
3. Keep the suggested name or type a new name for the anchor and click on OK 

 
To Hyperlink to a spot in the current page: 

1. Select the text or graphic to link 
2. Click on the Link tool and choose Drafts and Recent Pages 
3. Under Page Title, click on the current page name 
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4. If the Section Anchor box is not displayed at the bottom of the dialog box, click 
on the Advanced button. Click on the drop-down arrow next to Section Anchor 
and choose the anchor name 

5. Click on OK 
 
To Hyperlink to a spot on a page other than the current page: 

1. Open the file to link to and then close it. This will cause the file to now be listed 
in the Recent Pages list. 

2. Open the file in which you want to add the link. 
3. Select the text or graphic to link 
4. Click on the Link tool and choose Drafts and Recent Pages 
5. Under Page Title, click on the page name to be linked to 
6. If the Section Anchor box is not displayed at the bottom of the dialog box, click 

on the Advanced button. Click on the drop-down arrow next to Section Anchor 
and choose the anchor name 

7. Click on OK 
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Images and Movies 
 
IMAGE FILE TYPES THAT CAN BE IMPORTED INTO 
CONTRIBUTE 

• GIF (Graphic Interchange Format) – ideal for small images. 
• JPEG (Joint Photographic Experts Group) – ideal for photographs, and graphics 

with multiple colors. 
• PNG (Portable Network Graphic) – combines features of GIF and JPEG but 

doesn’t support animation and not supported by older browsers. 
 
IMPORTING AN IMAGE 

1. Place the cursor in the document where the picture should appear 

2. Click on the Image tool from the toolbar at the top of the screen  
3. Choose either From My Computer to From Website 
4. Navigate to the picture and double-click on it 
5. In the Image Description box, type a description of the image. This text will be 

read by screen readers to people with visual disabilities. 
6. Click on OK 

 
SIZING AN IMAGE 

1. Click on the image to select it 
2. Point to the bottom right-hand corner of the image. When the mouse pointer 

changes to a double-black arrow, click and drag to size the image. 
 

Tip:  To constrain the proportion of the image while sizing, point to the bottom right-
hand corner of the image, when the mouse pointer changes to the double-black 
arrow, press the Shift key on the keyboard and then drag the image to size it.  

 
MOVING AN IMAGE 

1. Click on the image to select it 
2. Point in the middle of the image and click and drag it to the desired location 

 
WRAP TEXT AROUND AN IMAGE 

1. Right-click on the image and choose Image Properties 
2. In the Alignment box, choose either Left or Right 

 
IMAGE ALIGNMENT 

1. Right-click on the image and choose Image Properties 
2. In the Alignment box, choose either Left, Right, Middle, or Top 
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IMAGE BORDER 
To place a border around an image: 

1. Right-click on the image and choose Image Properties 
2. Type a number in the Border box. The higher the number, the larger the border. 
3. Click on OK 

 
IMAGE EDITING 
Edit image features such as resize, crop, rotate, sharpen, brightness, and contrast. 

1. Right-click on the image 
2. Choose Edit Image 
3. Choose the desired editing feature. If cropping, once cropping box has been set, 

right-click on the image again and choose Edit Image and then Finish Crop. 
 
EDIT IMAGE IN EXTERNAL APPLICATION 
To perform more advanced editing on an image, the image can be opened in your default 
image editing application. To change the default program for editing images, go to the 
Edit menu, choose Preferences, and click on File Editors 

1. Right-click on the image 
2. Choose Edit Image in External Application 
3. When finished, Save the file and Exit the image editing application. 

 
WHERE ARE THE IMAGES STORED? 
When a file containing images is published, Contribute places a copy of the images in the 
Images folder in the folder where the file is published. 
 
INSERT FLASH MOVIES (SWF FILES) 

1. From the Insert menu choose Flash 
2. Choose From My Computer, From Website or From Shared Assets 
3. Navigate to the .swf file and click on Open 

 
FLASH MOVIE PROPERTIES 
Once a Flash Movie has been inserted, its properties 
can be changed. 

1. Click on the Flash movie to select it 
2. From the Format menu choose Flash Movie 

Properties 
3. Make desired changes 
4. Click on OK 

 
INSERT MOVIES 
The following movie types can be inserted in Contribute:  QuickTime (MOV), video files 
(MPG or MPEG), AVI, and Windows Media (WMV). 
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1. From the Insert menu choose Movie 
2. Choose From My Computer or From Website 
3. Navigate to the movie file and click on Open 

 
MOVIE PROPERTIES  
Once a movie is inserted, its properties can be 
changed. 

1. Right-click on the movie 
2. Choose Movie Properties 
3. Make desired changes 
4. Click on OK 
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Tools 
SHARED ASSETS 
Shared Assets is a library of information such as images that can be shared with all 
Contribute users at a site.   

1. Insert menu 
2. Shared Assets 
3. Choose the desired assets to insert and click on OK 

 
PDF AND FLASH FILES 
With Contribute 3 installed, you can quickly make PDF and Flash files from within 
Microsoft Word, Excel, and PowerPoint. 

1. Open the file to be converted 
2. From the FlashPaper menu or the FlashPaper toolbar, choose Convert to 

Macromedia Flash or Convert to PDF.  
3. Enter a Filename and location and click on Save 

 
NOTE: For accessibility, you should also include HTML versions of any PDF files. 
 
SPELL CHECK  
Press the F7 function key or from the Format menu choose Check Spelling. 
 
BLANK LINES IN A NUMBERED OR BULLETED LIST 
Pressing Shift-Enter at the end of a list item creates a new line instead of a new number 
or bullet. This allows for blank lines between items in the list or new lines without 
creating the next number or bullet.   
 
INSERTING A SPECIAL CHARACTER 

1. From the Insert menu choose Special 
Characters 

2. Choose a special character from the fly-out 
menu 

 
INSERTING A WORD DOCUMENT 

1. From the Insert menu choose Microsoft Office Document 
2. Navigate to the Word file and double-click on it 
3. Leave the first option selected and click on OK 

 
INSERTING CURRENT DATE 

1. From the Insert menu choose Date 
2. Select the date format 
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3. Click on Update Automatically on save if you want the date to be automatically 
updated each time you save the file 

4. Click on OK 
 
ROLL BACK 
After publishing a file, if you do not like the changes, you can roll back to up to five 
previous versions of the file.  

1. Select the file in the Sidebar on the left-hand side of the screen (or browse to the 
file) 

2. From the File menu, choose Roll Back to Previous Version 
3. Select the version to roll back to and click on the Roll Back button 

 
PAGE DESIGN TEMPLATES 
Our Webmaster has created some page designs that can be copied and pasted into a 
Contribute page.  The shapes are stored at http://draft.ed.uiuc.edu/help/library.html. This 
Web address is also listed in the Page Properties section at the bottom of pages while in 
the Editing mode. 
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Resources 
CONTRIBUTE HELP 
Help Menu 
From the Help menu choose Macromedia Contribute Help 
 
Help Button 
While in dialog boxes, a Help button is usually displayed in the lower left-hand corner. 
Click on the Help button to display help related to the current command. 
 
Sidebar 
The Sidebar in the left-hand side of the Contribute screen contains a How To section.  If 
the Sidebar is not displayed, from the View menu choose Sidebar. 
 
 
MACROMEDIA WEBSITE CONTRIBUTE TUTORIAL 
http://www.macromedia.com/support/documentation/en/contribute 
 
 


