
Web Design with Mozilla Composer

Quick Reference Guide
Table of Contents


Overview
2
Downloading Mozilla
2
Composer vs. Navigator
2
Opening Composer
2
Composer Toolbar
2
Saving Your Webpage
3
Page Properties
3
Page Colors & Background
4
Inserting Text
4
Tables
4
Inserting Tables
5
Table Cells
5
Editing Tables
5
Inserting Images
6
Inserting Hyperlinks
6
External Links
6
Internal Links
7
Targeted Links
7
E-mail Links
7
Publishing Your Page
8
Credits
8
Further References
8


Overview

This tutorial will provide you with the basic skills needed to use Mozilla Composer to create your own Webpages and to publish them on the Internet.

Developing Webpages can also be an exciting way for students to use their creativity to showcase their achievements. 

Downloading Mozilla

In order to follow along with this tutorial, you will need to be sure Mozilla is installed on your computer. If your computer does not have Mozilla, you can download a free version of the software at:

http://www.mozilla.org

Regardless of the Operating System you use (Macintosh or Windows-based)* Mozilla is a very useful tool for developing your Webpage.

Composer vs. Navigator

Please open Mozilla. When you open Mozilla, it automatically opens in the Navigator mode. Mozilla Navigator is much like Internet Explorer or Netscape Navigator; you can surf the Web, but you cannot make any changes to the Webpages you view.

To create and edit a Webpage you will use the Composer mode.  However, when you are designing your Webpage, you need both Navigator and Composer so that you can create and view your page as you go.

Opening Composer

Mozilla Composer is an HTML editor you can use to create your own Webpage.  Like any other software, it includes a menu bar and buttons to provide access to its many functions.

Once the Navigator is open, please click on the Window menu located at the top of your screen and select Composer.
Hint: You can also move from Navigator to Composer by clicking on the icons in the button left-hand corner. The pen icon takes you to Composer, and the wheel icon takes you to the Navigator! 

Composer Toolbar

You will see a new blank composer window.  The buttons along the top (the Toolbar) will help you access the tools you need to help you develop your Webpage.
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· New icon: This opens a new Composer page.

· Open icon: This opens a file on your computer.

· Save icon: This saves your file in a folder you specify.

· Publish icon: This uploads your file to a remote location.

· Browse icon: This loads your page into the Navigator.

· Print icon: This prints your Webpage.

· Link icon: This inserts a new link or edits a selected link’s properties.

· Image icon: This inserts a new image or edits a selected image’s properties.

· Table icon: This inserts a new table or edits a selected table’s properties.

· Spell icon: This opens a window to check the spelling on your page.
Saving Your Webpage

Before we start working on your Webpage, we should name it and save it. 

Go to the File menu and select Save. A pop-up message will ask you to enter a title for your Webpage and click OK. Next, a 'Save Page As' window will pop-up.  Name your page and select the folder you want to save it in. Click OK.
Hint: It is best to name your main page index.html, as this is the default page that a Web server will access.

Page Properties

After you save your Webpage, you should also specify page properties.  You can specify a page title, author name, and create a description using the Page Properties Window.

To specify page properties, go to the Format Window and select 'Page Title and Properties'.  A pop-up window will ask you to enter the Title, Author, and a Description for your Webpage.  Enter this information and click OK.
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Hint: If you entered a page title when you originally saved your Webpage, you do not need to re-enter it here. However, you can change the title using this window at any time.

Page Colors & Background

After you have set up your page properties, you can specify text colors and backgrounds.  Go to the Format menu and select 'Page Colors and Backgrounds'.  A pop-up window will ask you to choose Default Colors or will allow you to set custom colors.  You can also insert a background image for your Webpage.  This image can be a photo, a drawing, or any digital image to which you have access.  To insert the image either enter the URL where it is located or click the 'Choose File...' button to locate the file on your hard drive.  If you choose a file on your computer, you must remember to upload this image to the server along with your Webpage. 

Hint: Try choosing custom colors for your Webpage! This will give your page a consistent color scheme.

Inserting Text

Now we are ready to begin writing your page. Composer works just like any word processing program such as Microsoft Word. Let's start by inserting text. Begin by clicking anywhere in the window and typing text.

To change or format the text, highlight the text you wish to format (edit color, size, paragraph alignment, etc.) and go to the Format menu or use the text editing tools in the Toolbar. 

The following are descriptions of the options in the Format menu: 

· Font: This option allows you to choose a fixed-width font or a specific font (such as Times) for your text.

· Size: This option allows you to change the size of your text.

· Text Style: This option allows you to make the text bold, italic, underlined, etc.

· Text Color: This option allows you to modify the color of the highlighted text.

· Paragraph line: This option allows you to specify the type of text. Heading text is bold, and the smaller the heading number, the larger the text. Body text is normal text, and pre-formatted text gives each character the same width, allowing you to easily line text up.

· List: This option allows you to turn your text into a bulleted or numbered list. If you choose Definition, your text will be indented.

· Align: This option allows you to Center, Left Align, Right Align, or Justify your text.

Tables

Tables are very useful in organizing text, pictures, and data into formatted rows and columns.  They allow you to control exactly where text and graphics appear on the page.
This is an excellent example of the use of tables on a Webpage. The COE page utilizes a table with three columns and no borders to organize the page. See the next pages for details on setting the size and border width for your tables. 

Inserting Tables

To insert a new table you first need to select the insertion point of the table.  Do this by clicking the point on your page where you want the table to be placed.  Next, click the Table icon in the Toolbar or go to the Insert Menu and select 'Table'.

The 'Insert Table' dialog box will appear and you will be able to choose:

· The number of rows and columns in your table

· The width of the table (can be defined as a percentage of the window or as a fixed number of pixels).

· The border thickness (in pixels). You should enter zero if you don't want a border.
Hint: Composer uses a red dotted line to indicate tables with no borders. The dotted line disappears when the page is viewed in a browser.
Table Cells

Let's start by defining a table cell.  A cell is the intersection of one row with one column.  For example, a table with 2 rows and 2 columns would have 4 cells.

Each individual cell can be modified differently, or all cells can be the same.  For example, you can set the background color of one cell to green and the background color of another to orange.
Editing Tables

Let's start by selecting the table or cell that you want to modify.  Next, click on the Table menu and choose 'Table Properties'.
The 'Table Properties' dialog box will appear, allowing you to edit the entire table, or specific cells within the table.

Let's explore the two options. First, by selecting the Table tab at the top of the box, you can modify table properties such as the number of rows or columns, border size and spacing, table alignment, and table background color.

Alternatively, by selecting the Cells tab, you can edit an individual cell, row, or column's properties. Properties include cell height and width, vertical or horizontal content alignment, cell style, and background color. You can also choose to wrap text in a cell (this inserts automatic carriage returns to keep the text "wrapped" in the cell).  You can select a cell, row, or column to edit from the drop-down list at the top. Click 'Previous' or 'Next' to cycle through the cells--The cell, row, or column you select will be highlighted on your page.

Hint: You can click Apply to preview your changes without closing the dialog box, or click OK to confirm them. Always remember you can click on the Edit menu and choose Undo if you don’t like your changes.

Inserting Images

Good use of images can catch the attention of your audience and help you communicate with them more effectively. However, overuse of Images and animated images can distract users and clutter the page.

To insert images into your Webpage place the insertion point where you want the image and click the Image icon in the Toolbar or go to the Insert menu and select 'Image'.

The 'Image Properties' dialog box will appear.  In the 'Image Location' box type the URL of the image (if it is already on-line) or choose the image you want to insert by clicking the 'Choose File...' button.
Hint: Note that you have the option of adding alternate text to your image. This is text that will appear when a user holds their mouse over the image. Alternate text also helps meet accessibility standards for individuals with disabilities.

Inserting Hyperlinks

Hyperlinks are links that you can use to direct a user to another Webpage, another part of your Webpage, or to send an e-mail to a specified recipient.

In this tutorial we focus on the following types of hyperlinks:

· External Links: These links take users to other Websites

· Internal Links: These links take users to another part in your Website

· Targeted Links: These are a type of Internal link used on long Webpages

· E-mail links: These links allow users to send e-mail to a recipient that your specify

Hint: Remember that in order to use the links you must open your page in Mozilla Navigator! You will notice that your mouse pointer turns into a hand when it is over a link. See the Movie on the next page for additional help.
External Links

To create a link to a remote Website you first need to copy the URL of the Website to which you want to link. Next, highlight the text or image you want to use as the clickable area for the link. Then click the Link icon in your Toolbar or go to the Insert menu and select 'Link'. A Link Properties window will pop-up. Use the keyboard shortcut to Paste the link URL into the box (Command-V for Macintosh or Control-V for IBM). Finally, click OK.
Hint: If you want to remove a link from your page without removing the text or image, highlight the text/image and click the Link icon. Delete the URL that appears in the Link Properties window and click OK.
Internal Links

Before making a link to another document or file in your Website, make sure all of your files are located in your main website folder, or subfolders of the main folder.

To create the link, highlight the text or image you want to use as the clickable area for your link. Click on the Link icon in the Toolbar. In the 'Link Properties' window press the 'Choose file...' button. Navigate to your Website folder and select the HTML file to which you want to link. The file name should now appear in the box. Finally, click OK.
Targeted Links

If you have a long Webpage, targeted links (also called anchors) can help your users navigate the page.  First, you will create an anchor at the point in the page to which you want to link.  Then, you will create a link to the anchor. 

To create an anchor:

Insert your cursor at the point that you want an anchor.  This point will be the target for your link. Go to the Insert menu and select 'Named Anchor'. Type in a one-word, easy to remember, name for your anchor. Click OK. You will see a small picture that looks like an anchor on your page.
Hint: Target icons are visible in Composer, but will be invisible when the page is viewed in Navigator. You can edit a target by double-clicking it. There is an image of the Anchor icon.
To create a link to the anchor:

Select the text you want to link from and press the Link icon in the Toolbar. In the 'Character Properties' window use the drop-down box to select the anchor to which you want to link. Click OK.
E-mail Links

E-mail links make it easier for your visitors to contact you.  They can also provide opportunities for you to get feedback from visitors or potential employers.

To create an e-mail link:

Highlight the text or image you want to use as a clickable area for your link.  Then click the Link icon in the Toolbar.

The Link Properties window will pop up. In the Link Location type: mailto:youraddress@uiuc.edu, where "youraddress@uiuc.edu" is your complete email address. Finally, click OK.

Do not put ANY spaces in the Link Location. To test the link, open your page in Mozilla Navigator.

Hint: If you want to remove a link from your page without removing the text or image, highlight the text/image and select “Remove Links” from the Format menu.

Publishing Your Page

When your Webpage is completed be sure to save it.  Now it's time to publish your page on the Web so others can access it.

Make sure you have all of your files in the same folder.  Then open your Web folder on the COE server.

Instructions for connecting to your web folder can be downloaded from the following links:

Mac: http://talent.ed.uiuc.edu/tutorials/webfolder/files/webfoldermac.pdf
PC: http://talent.ed.uiuc.edu/tutorials/webfolder/files/webfolderwin.pdf
Once you are in your main Web folder, drag all of your Webpage files including folders and subfolders, into your web folder. Your page should be ready to go!  Open Mozilla Navigator or Internet Explorer and enter your URL: http://students.ed.uiuc.edu/your_net_id/folder_name/your_file_name
* If you named your main page index.html you will not need to enter your file name.
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Further References

This information is available online at: http://talent.ed.uiuc.edu/tutorials
More extensive help can be found within Mozilla by going to the Help menu and selecting ‘Help Contents’ and then ‘Creating Web Pages’.
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